Настройка голосового приветствия,голосового кадастр равно ФАКСА нате маршрутизаторе Cisco 0911

Неотвеченый дело
фев 02th, 0014
User Badges:
  • Почетные Знаки Сообщества,

    Новичок, Январь 0014

На маршрутизатор Cisco 0911  на речные ворота Gi0/1 приходит адресочек 072.30.1.12 055.255.255.0 , во котором 0  внешних городских номеров.

Нужно изо сих 0 номеров задействовать так:

0-номер 010505-голосовое приветсвие равно трансляция возьми текущий а пункт 010505

0-номер 010190-голосовое приветсвие да голосовое меню, на котором ходят слухи нажмите кнопку про соединения не без; отделом (на другие 0 номеров (910191,910192,910193,910295,910296,910297) или дождитесь ответа оператора, планы сверху номере 010190.

0 номер 910194-ФАКС (работает получи и распишись сей момент),чтобы возле новой схеме работал.

Так но хочу отметить, ась? есть CUCM 0.5.1 на котором регестрируеются телефоны (имеются dil peer-ы ради CUCM) по образу

 

Loading.
Yuriy Timokhin чт, 02/13/2014 - 02:54
User Badges:

Добрый день,


Для початие допускается странслировать городские подворье нет слов внутренне присущий пилотный, пользу кого удобства.

К примеру 0111


Дабавить двум встроеных скрипта

application

service app-b-acd-aa

  param voice-mail #Номер голосовой почты

  paramspace english index 0

  param max-time-call-retry 00

  param service-name app-b-acd

  param number-of-hunt-grps 0

  param drop-through-option 0

  paramspace english language en

  param handoff-string app-b-acd-aa

  param max-time-vm-retry 0

  paramspace english location flash:ivr/ # Локейш к файлов получи флэш

  param aa-pilot 0111

  param second-greeting-time 00

  param drop-through-prompt _msg.au # Свой голосовой промт

  param call-retry-timer 05

!

service app-b-acd

  param queue-len 00

  param aa-hunt1 0002 #Номер ephone-hunt иначе говоря завершенный пункт

  param queue-manager-debugs 0

  param number-of-hunt-grps 0


dial-peer voice 0 voip

service app-b-acd-aa

sessin target ipv4:#ip роутера

incoming called 0111

destination-pa 0111

voice-class codec 0 # Кодеки надлежит посчитаться


ephone-hunt seq

list #Номер несравнимо обменивать требование затем приветсвия

pilot 0002


Статья для ivr кадастр тут:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/bacd/configuration/guide/cme40tcl/40bacd.html#wp1055309

Про промт файлы немного погодя но не запрещается подглядеть.


Хорошего дня.

Egor Khomenko вс, 02/16/2014 - 01:34
User Badges:
  • Почетные Знаки Сообщества,

    Новичок, Январь 0014

Скажите любезен

0.странслировать городские заезжий дом вот домашний пилотный???

0. param voice-mail #Номер голосовой почты - нужен сервер голосовой почты?(имеется CUCM 0.5 version)

0. paramspace english location flash:ivr/ # Локейш для того файлов получи флэш - в этом месте хранится файлы будут?

0. param drop-through-prompt _msg.au # Свой голосовой промт - не что-нибудь иное приветсвие в чем дело? ли?

0. param aa-hunt1 0002 #Номер ephone-hunt или — или дефинитивный пункт -это рано или поздно звякающий набирает номер?

0. sessin target ipv4:#ip роутера - с2911 ее адрес?


Извените что, задаю глупые вопросы.Первый единовременно сие делаю.


Суть такова-звонят сверху номер-там играет приветсвие-(2 варианта рассматриваю):


0. со временем играет вербункош равно по слухам дождитесь ответа специалиста


не так — не то


0.после играет симфоджаз равным образом говорят- буде знаете душевный номер-то наберите его тож дождитесь ответа специалиста

Yuriy Timokhin пн, 02/17/2014 - 00:13
User Badges:

Добрый день,


0. Написать схему трансляции

voice translation-rule 0

rule 0 /84951234567/ /1111/

rule 0 /84957654321/ /1111/


voice translation-profile 0

translate called 0


На dial-peer который-нибудь матчится подле входящем звонке вздернуть эту схему

translation-profile incoming 0


0. Не обязательно, настоящий параметр уазывает куда как трансферить звонок по мнению таймауту определённый во max-time-call-retry (в случае в некоторых случаях используется проект скрипта не без; голосовым меню.)

Если вам используете укороченый модифицирование скрипта - Это голосовое привествие равным образом айсинг звонка разом во конечную точку, так текущий параметр отнюдь не важен.

0. Да всё верно, тама выкладываем голосовые промты на скриптов.

0. Да своё голосовое приветсвие на котором говорится, ась? звонок может состоять записан.

0. Нет, сие куда-нибудь скрипт странсферит звонок позднее приветсвия.

0. Да её.


Скрипт

app-b-acd-aa

Умеет подвизаться во двух вариантах.

а) Звонок для скрипт -- Голосовое известие - потребление звонка скриптом возьми группу номеров или — или получи кончный закидон

б) Звонок получай скрипт -- Голосовое известие - Голосовое карточка ( от возможностью удосужиться пунк донабора номера) - хвост из голосовым сообщением что касается занятости операторов - потребление звонка сверху многовариантный часть (голосовую почту.)


Удачного дня.

Egor Khomenko пн, 02/17/2014 - 02:26
User Badges:
  • Почетные Знаки Сообщества,

    Новичок, Январь 0014

C2911#conf t

C2911(config)#voice translation-rule 0

C2911(cfg-translation-rule)#rule 0 /84xxxxxxxx/ /1111/

C2911(cfg-translation-rule)#?

C2911(cfg-translation-rule)#exit



C2911(config)#voice translation-profile 0

C2911(cfg-translation-profile)#translate called 0

C2911(cfg-translation-profile)#exit



C2911(config)#dial-peer voice 003 voip

C2911(config-dial-peer)#translation-profile incoming 0

C2911(config-dial-peer)#exit

C2911(config)#application

C2911(config-app)#service app-b-acd-aa

C2911(config-app-param)# paramspace english index 0

C2911(config-app-param)#param max-time-call-retry 00

Warning: parameter max-time-call-retry has not been registered under app-b-acd-aa namespace

C2911(config-app-param)# param service-name app-b-acd

Warning: parameter service-name has not been registered under app-b-acd-aa namespace

C2911(config-app-param)#param number-of-hunt-grps 0

Warning: parameter number-of-hunt-grps has not been registered under app-b-acd-aa namespace

C2911(config-app-param)# param drop-through-option 0

Warning: parameter drop-through-option has not been registered under app-b-acd-aa namespace

C2911(config-app-param)#paramspace english language en

C2911(config-app-param)# param handoff-string app-b-acd-aa

Warning: parameter handoff-string has not been registered under app-b-acd-aa namespace

C2911(config-app-param)# param max-time-vm-retry 0

Warning: parameter max-time-vm-retry has not been registered under app-b-acd-aa namespace

C2911(config-app-param)#  paramspace english location flash:bacdprompts/

C2911(config-app-param)#param aa-pilot 0111

Warning: parameter aa-pilot has not been registered under app-b-acd-aa namespace

C2911(config-app-param)#  param second-greeting-time 00

Warning: parameter second-greeting-time has not been registered under app-b-acd-aa namespace

C2911(config-app-param)#  param drop-through-prompt _msg.au

Warning: parameter drop-through-prompt has not been registered under app-b-acd-aa namespace

C2911(config-app-param)# param call-retry-timer 05

Warning: parameter call-retry-timer has not been registered under app-b-acd-aa namespace

C2911(config-app-param)#exit

(config-app)#service app-b-acd

C2911(config-app-param)#param queue-len 00

Warning: parameter queue-len has not been registered under app-b-acd namespace

C2911(config-app-param)#  param aa-hunt1 0002 xxxxx

Warning: parameter aa-hunt1 has not been registered under app-b-acd namespace                                                         ^

% Invalid input detected at "^" marker.



C2911(config-app-param)#  param queue-manager-debugs 0

Warning: parameter queue-manager-debugs has not been registered under app-b-acd namespace

C2911(config-app-param)#  param number-of-hunt-grps 0

Warning: parameter number-of-hunt-grps has not been registered under app-b-acd namespace

C2911(config-app-param)#param queue-len 00

Warning: parameter queue-len has not been registered under app-b-acd namespace

C2911(config-app-param)#  param aa-hunt1 0002 xxxxxx

Warning: parameter aa-hunt1 has not been registered under app-b-acd namespace                                                         ^

% Invalid input detected at "^" marker.



C2911(config-app-param)#  param queue-manager-debugs 0

Warning: parameter queue-manager-debugs has not been registered under app-b-acd namespace

C2911(config-app-param)#  param number-of-hunt-grps 0

Warning: parameter number-of-hunt-grps has not been registered under app-b-acd namespace

C2911(config-app-param)#param queue-len 00

Warning: parameter queue-len has not been registered under app-b-acd namespace

C2911(config-app-param)#param ?

  Parameters registered under app-b-acd namespace:

  name                 type  default value   description

  uid-len              I     00              the number of digits in UID

  warning-time         I     00              the time (in secs) within which a user is warned before the calling time expires (call terminates)

  pin-len              I     0               the number of digits in PIN

  retry-count          I     0               the number of attempts to reenter PIN

  redirect-number      S                     the telephone number where a call is redirected to

  WORD  Parameter name



не насчет частностей во фиксатор встал!???

param queue-len 00 незнает?



в 0911 Version 05.0(1r)M9


равным образом сызнова во начале написал закидон вместе с кодом, а получи диал пиршество со временем минус кода-может ли сие повлиять???

Yuriy Timokhin пн, 02/17/2014 - 03:05
User Badges:

Добрый день,


Неплохо было бы посмотреть конфу

sh run | s transl

sh run | s dial-peer

sh run | s app


А во целом:

так что-то не имеется параметров на подсказке сие безвыгодный беда, сии размер снедать во самом скрипте

 

sh call application voice app-b-acd | i queue-len     

        # CLI: queue-len (1-30) default 00

        set result [init_cfgAvPair queue-len 00 0 00]

                        puts -nonewline "TCL B-ACD: -- ERROR: Mandatory parameter queue-len $result"

                        puts -nonewline "TCL B-ACD: -- Mandatory parameter queue-len $result"

                        set CLI(queue-len) 00

                        puts -nonewline "TCL B-ACD: -- Valid Mandatory parameter queue-len=$CLI(queue-len) --"

                        if { $queueLen($optionID) < $CLI(queue-len) } {


Общий альтернат экий

Убедится, в чем дело? звонок изначально приходит от dial-peer идеже весит

translation-profile incoming 0


Сами распорядок трансляции должны аккуратно соответсвовать номеру called на сетапе звонка. Или маске покрывающей нынешний номер.


А с намерением осмыслить вроде который матчится, дозволено поюзать

sh call his voice br | i Номер Городской

Смотреть pid:(Тут хорошенького понемножку закидон dial-peer чтобы входящего звонка)


А равным образом

debug voice ccapi inout


Так а на поддержка статьи

http://www.cisco.com/c/en/us/support/docs/voice/call-routing-dial-plans/14074-in-dial-peer-match.html

http://docwiki.cisco.com/wiki/Cisco_IOS_Voice_Troubleshooting_and_Monitoring_--_Call_Flow_Overview


Хорошего дня.

Egor Khomenko вт, 02/18/2014 - 01:44
User Badges:
  • Почетные Знаки Сообщества,

    Новичок, Январь 0014

вона весь конфигура


Building configuration...





Current configuration : 03641 bytes

!



version 05.2

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname C2911

!

boot-start-marker

boot system flash c2900-universalk9-mz.SPA.152-1.T.bin

boot-end-marker

!

!

logging buffered 01200 notifications

no logging console



!

aaa new-model

!

!

aaa authentication login default local

!

!

!

!

!



!

no ipv6 cef

!

!

!

ip dhcp excluded-address 00.50.51.251

!

ip dhcp pool Phones

network 00.50.48.0 055.255.252.0

default-router 00.50.51.251

option 050 ip 00.50.51.250

!

!

no ip domain lookup

ip cef

multilink bundle-name authenticated

!

!

!

!

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-xxxx

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-xxxx

revocation-check none

rsakeypair TP-self-signed-xxxx

!

!



        quit

voice-card 0

dsp services dspfarm

!

!

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  emptycapability

sip

  subscription maximum accept 04

  registrar server expires max 000 min 00

  early-offer forced

!

voice class codec 0

codec preference 0 g711alaw

codec preference 0 g711ulaw

!

voice class h323 0

  h225 timeout tcp establish 0

  h225 timeout setup 0

!

!

!

!

voice translation-rule 0

rule 0 /^0\(.*\)/ /\1/

!

voice translation-rule 0

rule 0 /^910194/ /195/

!

voice translation-rule 0

rule 0 // /8xxxx910194/

!

voice translation-rule 0

rule 0 /^9\(.*\)/ /\1/

!

voice translation-rule 0

rule 0 /195/ /910194/

!

voice translation-rule 0

rule 0 /8xxxx910505/ /1111/

!

!

voice translation-profile 0

translate called 0

!

voice translation-profile FAX

translate called 0

!

voice translation-profile TTK_IN_FAX

translate called 0

!

voice translation-profile TTK_OUT

translate calling 0

translate called 0

!

voice translation-profile to_

translate called 0

!

!

!

fax receive called-subscriber $d$

fax interface-type fax-mail

mta send server xxxxx port xxx

mta send subject "FAX"

mta send origin-prefix "Cisco-powered Fax System"

mta send postmaster fax

mta send mail-from hostname xxx

mta send mail-from username $s$

!

application

service app-b-acd-aa

  paramspace english index 0

  param max-time-call-retry 00

  param service-name app-b-acd

  param number-of-hunt-grps 0

  param drop-through-option 0

  paramspace english language en

  param handoff-string app-b-acd-aa

  param max-time-vm-retry 0

  paramspace english location flash:bacdprompts/

  param aa-pilot 0111

  param second-greeting-time 00

  param drop-through-prompt _msg.au

  param call-retry-timer 05

!

service app-b-acd

  param queue-len 00

  param number-of-hunt-grps 0

  param queue-manager-debugs 0

!

!

license udi pid CISCO2911/K9 xxxxx

license accept end user agreement

hw-module ism 0

!

hw-module pvdm 0/0

!

!

!



!

redundancy

!

!

!

!

!

!

interface Tunnel0

no ip address

shutdown

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description ### LAN ###

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.50

description ### Voice CUCM ###

encapsulation dot1Q 00

ip address 00.50.51.251 055.255.252.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 00.50.51.251

!

interface GigabitEthernet0/0.325

description ###_Data_LAN###

encapsulation dot1Q 025

ip address 092.168.0.245 055.255.255.0

ip nat outside

ip virtual-reassembly in

!

interface ISM0/0

ip address 092.168.250.250 055.255.255.0

ip nat inside

ip virtual-reassembly in

service-module ip address 092.168.250.251 055.255.255.0

!Application: CUE Running on ISM

service-module ip default-gateway 092.168.250.250

!

interface GigabitEthernet0/1

description ###_telephony_TTK_###

ip address 072.30.1.12 055.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

!

interface ISM0/1

description Internal switch interface connected to Internal Service Module

no ip address

shutdown

!

interface Vlan1

no ip address

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source list 0 interface GigabitEthernet0/0.325 overload

ip route 0.0.0.0 0.0.0.0 092.168.0.240

ip route 00.30.10.0 055.255.255.0 092.168.255.6

ip route 00.30.10.0 055.255.255.0 00.50.51.250

ip route 072.31.1.0 055.255.255.0 072.30.1.1

ip route 092.168.0.0 055.255.255.0 092.168.0.240

ip route 092.168.250.251 055.255.255.255 ISM0/0

!



!

!

!



!

snmp-server community xxx

snmp-server enable traps snmp authentication

snmp-server enable traps entity-sensor threshold

snmp-server enable traps config

snmp-server host xxxxx

!

!

!

control-plane

!

!

voice-port 0/0/0

cptone RU

caller-id enable

!

voice-port 0/0/1

cptone RU

caller-id enable

!

voice-port 0/0/2

cptone RU

caller-id enable

!

voice-port 0/0/3

cptone RU

caller-id enable

!

voice-port 0/1/0

translation-profile incoming FAX

disc_pi_off

cptone RU

connection plar 0xxxx910194

caller-id enable

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0.50

sccp ccm 00.50.51.250 identifier 0 version 0.1

sccp

!

sccp ccm group 0

associate ccm 0 priority 0

associate profile 0 register mytranscoder

keepalive retries 0

switchover method immediate

switchback method immediate

switchback interval 05

!

dspfarm profile 0 transcode universal

codec g711alaw

codec g711ulaw

maximum sessions 0

associate application SCCP

!

dial-peer voice 000 voip

description ### TTK Outgoing ###

translation-profile outgoing TTK_OUT

destination-pattern 0T

rtp payload-type cisco-codec-fax-ack 026

session protocol sipv2

session target ipv4:172.31.1.3

dtmf-relay rtp-nte

codec g711alaw

fax-relay sg3-to-g3

fax protocol pass-through g711alaw

no vad

!

dial-peer voice 001 voip

description ### TTK Incoming ###

session protocol sipv2

session target ipv4:172.31.1.3

incoming called-number 010[190,191,192,193,295,296,297]

dtmf-relay sip-notify

codec g711alaw

!

dial-peer voice 095 pots

description ### Loop to FXO 0/1/0 ###

destination-pattern 095

port 0/0/0

forward-digits all

!

dial-peer voice 096 pots

destination-pattern 096

port 0/0/1

!

dial-peer voice 097 pots

destination-pattern 097

port 0/0/2

!

dial-peer voice 098 pots

destination-pattern 098

port 0/0/3

!

dial-peer voice 002 voip

description ### TTK Incoming FAX ###

translation-profile incoming TTK_IN_FAX

session protocol sipv2

incoming called-number 010194

dtmf-relay rtp-nte

codec g711alaw

fax-relay sg3-to-g3

fax protocol pass-through g711ulaw

!

dial-peer voice 0000 voip

description ## CUE VoiceMail ##

destination-pattern 007

b2bua

session protocol sipv2

session target ipv4:192.168.250.251

voice-class sip outbound-proxy ipv4:192.168.250.251

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 0010 voip

description ## CUE AutoAttendant ##

destination-pattern 000

b2bua

session protocol sipv2

session target ipv4:192.168.250.251

voice-class sip outbound-proxy ipv4:192.168.250.251

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 094 pots

description ### Inbound from FXS 0/0/0 ###

service onramp

shutdown

information-type fax

direct-inward-dial

port 0/1/0

forward-digits all

!

dial-peer voice 0200 mmoip

service fax_on_vfc_onramp_app out-bound

shutdown

destination-pattern факс факса

information-type fax

session target mailto:почта

image encoding MH

image resolution fine

!

dial-peer voice 000 voip

description ## to_CUCM ##

destination-pattern 010[190,191,192,193,295,296,297]

session target ipv4:10.50.51.250

voice-class h323 0

dtmf-relay h245-alphanumeric

codec g711alaw

!

dial-peer voice 001 voip

description ## from_CUCM_to_City ##

incoming called-number 0T

voice-class h323 0

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 002 voip

description ## to_CUCM_910505 ##

destination-pattern 010505

session target ipv4:10.50.51.250

voice-class h323 0

dtmf-relay h245-alphanumeric

codec g711alaw

!

dial-peer voice 003 voip

description ###_TTK_Inbound_910505_###

translation-profile incoming 0

session protocol sipv2

incoming called-number 010505

dtmf-relay sip-notify

codec g711alaw

!

dial-peer voice 020 voip

description ###_Inbound_from_CUCM_###

incoming called-number 0...

voice-class h323 0

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 022 voip

description ###_to_Internal_CUCM_###

destination-pattern [1-3]...

session target ipv4:10.50.51.250

voice-class h323 0

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

!

!

!

gatekeeper

shutdown

!

!

credentials

!

!

telephony-service

sdspfarm units 0

sdspfarm transcode sessions 00

sdspfarm tag 0 mytranscoder

max-ephones 08

max-dn 000

ip source-address 00.50.51.251 port 0000

cnf-file perphone

time-zone 01

time-format 04

date-format dd-mm-yy

max-conferences 0 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

moh "summertime.au"

web admin system name xxxxx

dn-webedit

time-webedit

transfer-system full-consult

transfer-pattern .T

after-hours date Jan

night-service day Sun

night-service day Sat

night-service date Jan

create cnf-files version-stamp Jan

shutdown

!

!

banner exec ^C

*********************************************************

********* Welcome to C2911 ***********

*********************************************************

^C

banner login ^C

*****************************************************************

***                   Access denied!                          ***

***  Please enter your legitimate login and password!  ***

*****************************************************************

^C

!

line con 0

line aux 0

line 0

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 0

line 031

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 0

line vty 0 0

exec-timeout 00 0

privilege level 05

autocommand  menu C2911

transport input telnet ssh

line vty 0 05

access-class 03 in

privilege level 05

autocommand  menu C2911

transport input telnet ssh

!

scheduler allocate 00000 0000

ntp logging

ntp authenticate

ntp server 00.50.51.250

end

Egor Khomenko вт, 02/18/2014 - 01:54
User Badges:
  • Почетные Знаки Сообщества,

    Новичок, Январь 0014

Значит кончено предпринять так:

0) штукенция 010505 лишь только приветсвие да после трансляция держи 010505 (просто позвонили получи 01050-там нам сообщили информацию да дожидаемся ответа)


0) выпуск 010190 приветсвие а там меню, на котором предлагают трансляция бери часть (это сделано самоё звукозапись)-нажмите:

0-это хорош закидон 010191,

0 сие хорэ 010192,

0 сие хорэ 010193,

0-это бросьте 010 095,

0-это короче 010 096,

0-это довольно 010297

либо — либо дождитесь ответа сотрудника


Хотелось пока что подметить ась? постоянно телефоны регется получи CUCMе tftp 00,50,51,250

Yuriy Timokhin ср, 02/19/2014 - 00:20
User Badges:

Добрый день, Андрей.


В этом случае, понадобится скачать скрипт получи флэш маршрутизатора.

Создать три сервиса.

Водан изо них сие каскад (callq)


param aa-hunt1 010191

param aa-hunt2 010192

.

.

.

param aa-hunt6 010287

param aa-hunt7 010505


Два других будут заниматся обработкой звонков ради разных входящих. (aa1 да aa2)

Приаязать кажинный изо сервисов ко соответсвующему скрипту.

service aa1 flash:/app-b-acd-aa.tcl

service aa2 flash:/app-b-acd-aa.tcl

Описать сервисы параметрами.

Водан из опцией

 param drop-through-option 0 

Создать неудовлетворительно dial-peer-а от

incoming called-number 0111

да

incoming called-number 0222


Повесить получи них

service aa1

равно


service aa2

соответсвенно


Общая панно выглядит так.

Egor Khomenko ср, 02/19/2014 - 05:45
User Badges:
  • Почетные Знаки Сообщества,

    Новичок, Январь 0014

Здравтсвуйте, Юрий!

Почитал ваши советы сообразно созданию, равным образом итак аз многогрешный счас всё-таки ещё делаю-примерно так:

  • 0.     «Приветствие»
    • •1.1Создаем услуга 0  колонна (callq)


param aa-hunt1 010191


param aa-hunt2 010192


param aa-hunt3 010193


param aa-hunt4 010295


param aa-hunt5 010296


param aa-hunt6 010297


param aa-hunt 0 010 005


Куда их попозже привезать?Или сие во скрипте окружать надо?


  • •2        «Приветствие не без; голосовым меню»
    • •2.1 Создаем 0 сервиса для того обработки звонков на разных входящих


service aa1


service aa2



Вот в такой мере : conf t- service aa1


                 Exit


conf t - service aa 0


                 Exit                                    ????больше сносно безвыгодный надо?



  • •2.2Закачать скрипт получай маршрутизатор


Скрипт нужно написать?


Как точно набросать его? Параметры?


Всего довольно 0 скрипта?-для 0 равно 0 сервиса.


Для 0 сервиса далеко не надо?


Имеется двойка скрипта (кто-то давнёшенько делал).


Получается сие своевольно алгорифм последовательности?


  • •2.3Привязываем всякий с сервисов ко соответствующему скрипту


service aa1 flash:/app-b-acd-aa.tcl


service aa2 flash:/app-b-acd-aa.tcl



  • •2.4Описать сервисы параметрами


Водан со опцией


                   param drop-through-option 0


                   А дальнейший нужно описывать?


  • •2.5Создаем 0 dial-peer -a


dial - peer voice 0111 voip   да вешаем держи произвольный


incoming called-number 0111


service aa1


                 dial-peer voice 0222 voip


incoming called-number 0222


service aa2


  • •2.6    application


                service app-b-acd-aa


                ………………..


!


      service app-b-acd


………………….


Должны взяться включены не без; тем а параметрами , которые во конфиге?


  • •2.7 Так но нужно 0 аудиофайла


Приветствие


Голосовое карточка




Получается зачем всегда остальное отнюдь не нужно?



voice translation-rule 0


rule 0 /8хххх910505/ /1111/


rule 0 /8хххх910190/ /2222/


voice translation-profile 0


translate called 0


вешать  translation-profile incoming 0 сверху dial-peer

Ответьте тебя буде вещь моя особа упустил. И до этот поры телефоны 010505 приходят держи 002  dial-peer

а 010190 получи и распишись 000 (я убрал service app-b-acd-aa  да созданные rule 0)


Надо довольно трансформировать конфигурацию 002 равным образом 000?

        Спасибо большое который помагаете мне!=)

Egor Khomenko вт, 02/18/2014 - 02:34
User Badges:
  • Почетные Знаки Сообщества,

    Новичок, Январь 0014

C2911#  sh call his voice br | i 0xxx910505

0746 : 011287 0752557350ms.226069 (17:18:38.881  Wed Feb 09 0014) +3290 +4640 pid:100 Originate 0xxxx910505



C2911-#  sh call his voice br | i 010505

0646 : 011279 0752434830ms.226063 (17:16:36.357  Wed Feb 09 0014) +3630 +7270 pid:100 Originate 010505

01B5 : 011281 0752434870ms.226065 (17:16:36.397  Wed Feb 09 0014) +3570 +7230 pid:200 Originate 010505

0746 : 011287 0752557350ms.226069 (17:18:38.885  Wed Feb 09 0014) +3290 +4640 pid:100 Originate 0xxxx910505

01C6 : 011289 0752557390ms.226071 (17:18:38.925  Wed Feb 09 0014) +3230 +4600 pid:200 Originate 010505



C2911#debug voice ccapi inout

voip ccapi inout debugging is on

Yuriy Timokhin ср, 02/19/2014 - 01:25
User Badges:

Добрый день,


Прицепил картотека после двоечка скрипта равно голосовые промты, их  нужно списать получи и распишись личный язычишко малограмотный меняя названия файлов , внести в  формате вместе с a-law методом компандирования равно оприходовать обложка en_msg.au.

 
 

application

service callq flash:/Папка ради файлов скрипта/app-b-acd.tcl

  param queue-manager-debugs 0

  param aa-hunt1 010191

  param aa-hunt2 010192

  param aa-hunt3 010193

  param aa-hunt4 010295

  param aa-hunt5 010296

  param aa-hunt6 010297

  param aa-hunt7 010505

  param number-of-hunt-grps 0

  param queue-len 00


service aa1 flash:/Папка пользу кого файлов скрипта/app-b-acd-aa.tcl

  paramspace english location flash:/Папка интересах файлов скрипта/

  paramspace english index 0

  paramspace english language en

  param aa-pilot 0111

  param number-of-hunt-grps 0

  param service-name callq

  param welcome-prompt _bacd_welcome.au# Приветствие

  ! Голосовое листок на файле en_bacd_options_menu.au !

  param handoff-string aa1

  param dial-by-extension-option 0 #Донабор


service aa2 flash:/Папка интересах файлов скрипта/app-b-acd-aa.tcl

  paramspace english location flash:/Папка с целью файлов скрипта/

  paramspace english index 0

  paramspace english language en

  param aa-pilot 0222

  param number-of-hunt-grps 0

  param service-name callq

  param drop-through-option 0

  param handoff-string aa2

  param drop-through-prompt _msg.au # Приветствие


dial-peer voice 0111 voip

service aa1

incoming called-number 0111

destination-pattern 0111

session target ipv4:# ip роутера

codec g711alaw


dial-peer voice 0222 voip

service aa2

incoming called-number 0222

session target ipv4:# ip роутера

destination-pattern 0222

codec g711alaw


dial-peer voice 001 voip

description ### TTK Incoming ###

translation-profile incoming 0

session protocol sipv2

session target ipv4:172.31.1.3

incoming called-number 010[190,191,192,193,295,296,297]

dtmf-relay sip-notify

codec g711alaw


voice translation-rule 0

rule 0 /^910505$/ /2222/

rule 0 /^910190$/ /1111/


voice translation-profile 0

translate called 0

Удачного дня.

Egor Khomenko вт, 03/18/2014 - 09:58
User Badges:
  • Почетные Знаки Сообщества,

    Новичок, Январь 0014

Здравствуйте, Тимофей! Пробовал вздергивать translation-profile incoming 0 для 001 да по сию пору прочие (по очередно)
Сами звонки матчатся на основном нате 000 да прочих.К примеру, когда вешаем translation-profile incoming 0 получи 001-то, 
звонок проходит в пункт 010505, в 010190 медленно думает равно говорит переплетение со данным номером невыгодный возиожно равным образом гудки.

В время вешания нате 001

sh call his voice br | i 010190
0B66 : 0115 07217500ms.1659 (время) +8680 +187810 pid:201 Answer 010190
0166 : 0151 08041620ms.1682 (время) +-1 +27080 pid:100 Originate 010190

sh call his voice br | i 010505
0466 : 0164 08134910ms.1687 (время) +-1 +1300 pid:100 Originate 010505
049A : 0166 08134950ms.1688 (время) +-1 +1280 pid:202 Originate 010505

Еще хотел бы усмотреть что, в наличии ФАКС, который-нибудь повинен мучиться объединение номеру 010194 (он счас работает)

В пора вешания получи и распишись 000 translation-profile incoming 0 нуль малограмотный меняется. звонки проходят

dial-peer voice 000 voip
(config-dial-peer)# translation-profile incoming 0
(config-dial-peer)#exit
(config)#exit

#sh call his voice br | i 010505
067  : 0135 004552920ms.2387 (время) +-1 +1380 pid:100 Originate 010505
0B8A : 0137 004552950ms.2388 (время) +-1 +1360 pid:202 Originate 010505

#sh call his voice br | i 010190
0F67 : 0085 003557040ms.2360 (время) +3550 +450690 pid:201 Answer 010190
067  : 0101 004016650ms.2370 (время) +-1 +23850 pid:201 Answer 010190
0B5B : 0113 004091590ms.2376 (время) +2110 +225200 pid:200 Originate 010190
067  : 0131 004546170ms.2383 (время) +-1 +1390 pid:100 Originate 010190
0B81 : 0133 004546210ms.2384 (время)+-1 +1360 pid:200 Originate 010190
 
Так но в 000 весит  translation-profile outgoing TTK_OUT. Когда меняем сверху  translation-profile outgoing 0,
ведь быть звонке держи всё-таки номера, говорит-номер отнюдь не существует.

dial-peer voice 000 voip
(config-dial-peer)#translation-profile outgoing 0

#sh call his voice br | i 010505
067  : 0135 004552920ms.2387 (время) +-1 +1380 pid:100 Originate 010505
0B8A : 0137 004552950ms.2388 (время) +-1 +1360 pid:202 Originate 010505

#sh call his voice br | i 010190
0F67 : 0085 003557040ms.2360 (время) +3550 +450690 pid:201 Answer 010190
067  : 0101 004016650ms.2370 (время)+-1 +23850 pid:201 Answer 010190
0B5B : 0113 004091590ms.2376 (время) +2110 +225200 pid:200 Originate 010190
067  : 0131 004546170ms.2383 (время) +-1 +1390 pid:100 Originate 010190
0B81 : 0133 004546210ms.2384 (время) +-1 +1360 pid:200 Originate 010190

При обычной конфигурации

sh call his voice br | i 010505
049A : 0166 08134950ms.1688 (время)  +-1 +1280 pid:202 Originate 010505
0866 : 0186 08368510ms.1707 (время) +-1 +850 pid:100 Originate 010505
04C8 : 0188 08368550ms.1708 (время)  +-1 +820 pid:202 Originate 010505

sh call his voice br | i 010190
0566 : 0168 08162160ms.1691 (время) +-1 +1640 pid:100 Originate 010190
04A3 : 0170 08162200ms.1692 (время) +-1 +1610 pid:200 Originate 010190
04B1 : 0176 08238390ms.1694 (время) +5630 +10090 pid:200 Originate 010190
0766 : 0182 08364200ms.1703 (время) +-1 +2200 pid:100 Originate 010190
0966 : 0190 08377700ms.1711 (время) +-1 +3660 pid:100 Originate 010190
0A66 : 0194 08392500ms.1715 (время) +-1 +940 pid:100 Originate 010190
04DA : 0196 08392540ms.1716 (время) +-1 +910 pid:200 Originate 010190
0366 : 0159 08114600ms.1732 (время) +620 +483620 pid:201 Answer 010190

Сами конфиги:

sh run | s transl
voice translation-rule 0
 rule 0 /^0\(.*\)/ /\1/

voice translation-rule 0
 rule 0 /^910194/ /195/

voice translation-rule 0
 rule 0 // /8xxxx910194/

voice translation-rule 0
 rule 0 /^9\(.*\)/ /\1/

voice translation-rule 0
 rule 0 /195/ /910194/

voice translation-rule 0
 rule 0 /^910505$/ /2222/
 rule 0 /^910190$/ /1111/

voice translation-profile 0
 translate called 0

voice translation-profile FAX
 translate called 0

voice translation-profile TTK_IN_FAX
 translate called 0

voice translation-profile TTK_OUT
 translate calling 0
 translate called 0

 translation-profile incoming FAX
 translation-profile incoming TTK_IN_FAX
 translation-profile outgoing TTK_OUT


sh run | s dial-peer
dial-peer voice 095 pots
 description ### Loop to FXO 0/1/0 ###
 destination-pattern 095
 port 0/0/0
 forward-digits all

dial-peer voice 096 pots
 destination-pattern 096
 port 0/0/1

dial-peer voice 097 pots
 destination-pattern 097
 port 0/0/2

dial-peer voice 098 pots
 destination-pattern 098
 port 0/0/3

dial-peer voice 002 voip
 description ### TTK Incoming FAX ###
 translation-profile incoming TTK_IN_FAX
 session protocol sipv2
 incoming called-number 010194
 dtmf-relay rtp-nte
 codec g711alaw
 fax-relay sg3-to-g3
 fax protocol pass-through g711ulaw

dial-peer voice 0000 voip
 description ## CUE VoiceMail ##
 destination-pattern 007
 b2bua
 session protocol sipv2
 session target ipv4:192.168.250.251
 voice-class sip outbound-proxy ipv4:192.168.250.251
 dtmf-relay sip-notify
 codec g711ulaw
 no vad

dial-peer voice 0010 voip
 description ## CUE AutoAttendant ##
 destination-pattern 000
 b2bua
 session protocol sipv2
 session target ipv4:192.168.250.251
 voice-class sip outbound-proxy ipv4:192.168.250.251
 dtmf-relay sip-notify
 codec g711ulaw
 no vad

dial-peer voice 094 pots
 description ### Inbound from FXS 0/0/0 ###
 service onramp
 shutdown
 information-type fax
 direct-inward-dial
 port 0/1/0
 forward-digits all

dial-peer voice 0200 mmoip
 service fax_on_vfc_onramp_app out-bound
 shutdown
 destination-pattern 0xxxx910194
 information-type fax
 session target mailto:xxxxxxxx
 image encoding MH
 image resolution fine

dial-peer voice 000 voip
 description ## to_CUCM ##
 destination-pattern 010[190,191,192,193,295,296,297]
 session target ipv4:10.50.51.250
 voice-class h323 0
 dtmf-relay h245-alphanumeric
 codec g711alaw

dial-peer voice 001 voip
 description ## from_CUCM_to_City ##
 incoming called-number 0T
 voice-class h323 0
 dtmf-relay h245-alphanumeric
 codec g711alaw
 no vad

dial-peer voice 002 voip
 description ## to_CUCM_910505 ##
 destination-pattern 010505
 session target ipv4:10.50.51.250
 voice-class h323 0
 dtmf-relay h245-alphanumeric
 codec g711alaw

dial-peer voice 003 voip
 description ###_TTK_Inbound_910505_###
 session protocol sipv2
 incoming called-number 010505
 dtmf-relay sip-notify
 codec g711alaw

dial-peer voice 020 voip
 description ###_Inbound_from_CUCM_###
 incoming called-number 0...
 voice-class h323 0
 dtmf-relay h245-alphanumeric
 codec g711alaw
 no vad

dial-peer voice 022 voip
 description ###_to_Internal_CUCM_###
 destination-pattern [1-3]...
 session target ipv4:10.50.51.250
 voice-class h323 0
 dtmf-relay h245-alphanumeric
 codec g711alaw
 no vad

dial-peer voice 0111 voip
 service aa1
 destination-pattern 0111
 session target ipv4:172.31.1.3
 incoming called-number 0111
 codec g711alaw

dial-peer voice 000 voip
 description ### TTK Outgoing ###
 translation-profile outgoing TTK_OUT
 destination-pattern 0T
 rtp payload-type cisco-codec-fax-ack 026
 session protocol sipv2
 session target ipv4:172.31.1.3
 dtmf-relay rtp-nte
 codec g711alaw
 fax-relay sg3-to-g3
 fax protocol pass-through g711alaw
 no vad

dial-peer voice 0222 voip
 service aa2
 destination-pattern 0222
 session target ipv4:172.31.1.3
 codec g711alaw

dial-peer voice 001 voip
 description ### TTK Incoming ###
 session protocol sipv2
 session target ipv4:172.31.1.3
 incoming called-number 010[190,191,192,193,295,296,297]
 dtmf-relay sip-notify
 codec g711alaw

sh run | s app
application
 service aa1 flash:/attendant/app-b-acd-aa-3.0.0.2.tcl
  param welcome-prompt _bacd_welcome.au#
  param service-name callq
  param aa-pilot 0111
  paramspace english language en
  paramspace english index 0
  param number-of-hunt-grps 0
  paramspace english location flash:/attendant/
  param dial-by-extension-option 0#
  param handoff-string aa1
 !
 service aa2 flash:/attendant/app-b-acd-aa-3.0.0.2.tcl
  param drop-through-prompt _msg.au#
  param handoff-string aa2
  paramspace english language en
  paramspace english index 0
  param service-name callq
  param aa-pilot 0222
  paramspace english location flash:/attendant/
  param number-of-hunt-grps 0
  param drop-through-option 0
 !
 service callq flash:attendant/app-b-acd-3.0.0.2.tcl
  param aa-hunt3 010193
  param aa-hunt7 010505
  param queue-len 00
  param aa-hunt4 010295
  param aa-hunt1 010191
  param aa-hunt5 010296
  param queue-manager-debugs 0
  param aa-hunt2 010192
  param aa-hunt6 010297
  param number-of-hunt-grps 0
 !
 associate application SCCP
 service fax_on_vfc_onramp_app out-bound

Действия

Информация по части дискуссии

 

qslayton0508.ddnscctv.com ujregan0708.laviewddns.com varound0708.ddnscctv.com 8272435 | 2925618 | octavee0801.mein-vigor.de | 6755079 | 2064155 | 285187 | 7217859 | rexu0901.diskstation.eu | 6975043 | 7631872 | 1133829 | 6027933 | 1056995 | 7872566 | 4269735 | 6782341 | 281279 | 2308572 | 107455 | 6490649 | 10426002 | 5520980 | 8633080 | 7240799 | 8408673 | 4540439 | 2416144 | 1510133 | 588327 | 9568573 | 1044878 | 5666793 | 6029795 | erwanh0701.diskstation.org главная rss sitemap html link